SUBJECTS
|
BROWSE
|
CAREER CENTER
|
POPULAR
|
JOIN
|
LOGIN
Business Skills
|
Soft Skills
|
Basic Literacy
|
Certifications
About
|
Help
|
Privacy
|
Terms
|
Email
Search
Test your basic knowledge |
CCIE Sec Encryption Ipsec
Start Test
Study First
Subjects
:
cisco
,
it-skills
,
ccie
Instructions:
Answer 50 questions in 15 minutes.
If you are not ready to take this test, you can
study here
.
Match each statement with the correct term.
Don't refresh. All questions and answers are randomly picked and ordered every time you load a test.
This is a study tool. The 3 wrong answers for each question are randomly chosen from answers to other questions. So, you might find at times the answers obvious, but you will see it re-enforces your understanding as you take the test each time.
1. Negotiation of the ISAKMP policy by offering and acceptance of protection suites
2. Key exchange for IPSEC
AES
IKE
AH/ESP
Tunnel Mode (ipsec)
3. 'It is not used for encryption or digital signatures; it is used to obtain a shared secret
Difffie-Hellman
DSA
SHA
RSA
4. That authenticate data packets and ensure that data is not tampered with or modified.
hash-based message authentication codes (HMAC).
Origin Auth (DH auth)
hash algorithms
IPSEC BENEFIT
5. ID exchange and authentication of D-H key by using the reply to the received nonce or string of bits
6. Provides authentication and encryption of the payload.
IPSEC
AH
3DES
ESP
7. IPSEC performs this function by using a sequence field in the IPsec header combined with integrity checks.
hash algorithms
Antireplay
DSA
IPSEC (aggressive mode)
8. Integrity checks are done
9. 'Encryption - where Peer X uses Peer Y
Difffie-Hellman
Difffie-Hellman
Asymetric Encryption Protocols
RSA
10. A variable block- length and key-length cipher.
Difffie-Hellman
hash-based message authentication codes (HMAC).
3DES
AES
11. Act of encapsulating a packet within another packet.
DSA
DES
Tunneling
Difffie-Hellman
12. IPsec implements using a shim header between L2 and L3
RSA
IKE
AH/ESP
IKE
13. More CPU intensive
Asymetric Encryption Protocols
GRE
IKE
SHA
14. Verify whether the data has been altered.
Hashing
ISAKMP
DSA
DES
15. Hybrid protocol that defines the mechanism to derive authenticated keying material and negotiation of security associations (SA).
IKE
'MD5 - SHA-1 - or RSA'
'IPSEC (phase1 -step2)'
MD5
16. 'is a block-cipher algorithm - which means that it performs operations on fixed-length data streams of 64-bit blocks. The key ostensibly consists of 64 bits; however - only 56 are actually used by the algorithm.'
IPSEC BENEFIT
Origin Auth (DH auth)
DES
Difffie-Hellman
17. 'MACs with hash algorithms -'
DSA
MD5
hash-based message authentication codes (HMAC).
RSA
18. IPSec SAs are negotiated and protected by the existing IPsec SA.
IPSEC (phase2)
IPSEC (aggressive mode)
3DES
RSA
19. Uses the D-H algorithm to come to agreement over a public network.
IKE
IPSEC BENEFIT
Asymetric Encryption Protocols
'IPSEC (phase1 -step3)'
20. Main mode establishes ISAKMP security association in six messages and performs authenticated D-H exchange.
RSA
IPSEC (main mode)
Difffie-Hellman
3DES
21. Used for integrity checks on peer and data sent by peer and for authentication checks.
AH
IKE
3DES
RSA
22. Is a two-phase protocol: The first phase establishes a secure authenticated channel and the second phase is where SAs are negotiated on behalf of the IPsec services.
RSA
IKE
3DES
MD5
23. 'produces a 160-bit hash output - which makes it more difficult to decipher.'
IPSEC
Transport Mode (Ipsec)
SHA
'IPSEC (phase1 -step3)'
24. The receiving device then encrypts the data with the second key.
3DES
ESP
ISAKMP
IPSEC (main mode)
25. 'group 2 identifies a 1024-bit key - group 2 is more secure - but slower to execute.'
3DES
ESP
Difffie-Hellman
IKE
26. The sending device encrypts for a final time with another 56-bit key.
IKE
3DES
Difffie-Hellman
SHA
27. Common key size is 1024 bits.
RSA
IKE
AH/ESP
ESP
28. It also provides protection for ISAKMP peer identities with encryption.
IPSEC (main mode)
Hashing
ISAKMP
3DES
29. Used in government installs and was created to work with the SHA-1 hash algorithm.
DSA
Tunnel Mode (ipsec)
'MD5 - SHA-1 - or RSA'
3DES
30. Drawback of this is that the hash is passed unencrypted and is susceptible to PSK crack attacks.
MD5
ESP
IPSEC (aggressive mode)
RSA
31. It uses UDP 500 and is defined by RFC 2409.
SHA
RSA
'IPSEC (phase1 -step3)'
IKE
32. 'Created by NIST in 1994 - is the algorithm used for digital signatures but not for encryption.'
IPSEC (main mode)
DSA
MD5
3DES
33. Can be implemented efficiently on a wide range of processors and in hardware.
IKE
AES
GRE
IPSEC BENEFIT
34. Origin authentication validates the origin of a message upon receipt; this process is done during initial communications.
AES
Difffie-Hellman
IPSEC BENEFIT
DSA
35. Message of arbitrary length is taken as input and produces as output a 128-bit fingerprint or message digest of the input.
Hashing
Difffie-Hellman
MD5
3DES
36. 'is a more secure version of MD5 - and hash-based message authentication codes (HMAC) provides further security with the inclusion of a key-based hash.'
'IPSEC (phase1 -step1)'
Difffie-Hellman
SHA
Difffie-Hellman
37. 'requires that the sender and receiver have key pairs. By combining the sender
Difffie-Hellman
DSA
AES
'IPSEC (phase1 -step2)'
38. The DES algorithm that performs 3 times sequentially.
3DES
IPSEC (aggressive mode)
'IPSEC (phase1 -step2)'
ISAKMP
39. Negotiation of a shared secret key for encryption of the IKE session using the D-H algorithm
40. 'Digital signatures. Peer X encrypts a hash value with his private key and then sends the data to Peer Y. Peer Y obtains Peer X
RSA
ISAKMP
Difffie-Hellman
IPSEC (main mode)
41. No additional Layer 3 header is created. The original Layer 3 header is used.
Transport Mode (Ipsec)
GRE
3DES
DES
42. One of the most popular tunneling protocols is
IPSEC (main mode)
IPSEC BENEFIT
GRE
AH/ESP
43. 'Message digest algorithms have a drawback whereby a hacker (man in the middle) can intercept a message containing the packet and hash values - then re-create and transmit a modified packet with the same calculated hash to the target destination.'
MD5
Hashing
IKE
ISAKMP
44. Invented by Ron Rivest of RSA Security (RFC 1321).
ESP
IKE
MD5
'MD5 - SHA-1 - or RSA'
45. 'Finally - the receiving devices decrypt the data with the first key.'
Difffie-Hellman
SHA
3DES
RSA
46. 'key exchange is vulnerable to a man-in-the-middle attack. You can rectify this problem by allowing the two parties to authenticate themselves to each other with a shared secret key - digital signatures - or public-key certificates.'
Difffie-Hellman
IPSEC (phase2)
'DES - 3DES - or AES.'
Asymetric Encryption Protocols
47. 'algorithm encrypts and decrypts data three times with 3 different keys - effectively creating a 168-bit key.'
message authentication codes (MAC).
3DES
MD5
Difffie-Hellman
48. Uses protocol number 50.
RSA
Difffie-Hellman
Transport Mode (Ipsec)
ESP
49. ' is defined in RFC 3174. has as output a 160-bit value -'
MD5
IPSEC (aggressive mode)
SHA
IKE
50. 'group 1 identifies a 768-bit key - group 1 is faster to execute - but it is less secure -'
Difffie-Hellman
IKE
DSA
3DES