SUBJECTS
|
BROWSE
|
CAREER CENTER
|
POPULAR
|
JOIN
|
LOGIN
Business Skills
|
Soft Skills
|
Basic Literacy
|
Certifications
About
|
Help
|
Privacy
|
Terms
|
Email
Search
Test your basic knowledge |
IPV4 Addressing
Start Test
Study First
Subject
:
it-skills
Instructions:
Answer 50 questions in 15 minutes.
If you are not ready to take this test, you can
study here
.
Match each statement with the correct term.
Don't refresh. All questions and answers are randomly picked and ordered every time you load a test.
This is a study tool. The 3 wrong answers for each question are randomly chosen from answers to other questions. So, you might find at times the answers obvious, but you will see it re-enforces your understanding as you take the test each time.
1. Disables the sending of ICMP redirect messages
Per-Hop Behaviour (PHB)
Router(config-if)#no ip redirects
Application
Acknowledgements - checksums and timers
2. What mechanism is used by TCP to regulate the flow of segments?
RFC 1918
IP Precedence (3-bit); ToS (4-bit); Reserved (1-bit)
Host-to-host
Windowing
3. What is the format of the Flags field in the IPv4 header?
2
Network interface
Reserved (1-bit); DF (1-bit); MF (1-bit)
255.255.255.192
4. What is the format of the TCP Header Length field?
Number of octets - starting with the octet indicated by the Acknowledgement Number - that the receiver will accept from the sender before the sender must stop transmitting and wait for a new Acknowledgement
DHCP
Router#debug arp
Length of header in words (32-bit)
5. What is RST?
Reserved (1-bit); DF (1-bit); MF (1-bit)
Reset
Internet Assigned Numbers Authority
Sequence Numbers
6. What is the ARP Operation value for an ARP Reply?
64
127.0.0.0/8
89
2
7. What are classful routing protocols?
8. What is OSI?
Open Systems Interconnection
Used by a host to obtain the IPv4 address associated with its own MAC address
Sequence Number
Internet Protocol
9. What are the private IPv4 address ranges?
CWR (1-bit); ECE (1-bit); URG (1-bit); ACK (1-bit); PSH (1-bit); RST (1-bit); SYN (1-bit); FIN (1-bit)
Time Exceeded
Regional Internet Registry
10.0.0.0/8; 172.16.0.0/12; 192.168.0.0/16
10. What TCP/IP protocol suite layer corresponds to the physical and data link layers of the OSI model?
Network interface
192.0.2.0/24
Acknowledgement
1
11. What is the other name for the TCP Header Length field?
DSCP (6-bit); ECN (2-bit)
Reset
Urgent
Data Offset
12. Who group public IPv4 address space by major geographic region?
Router#debug arp
Uniquely identify every application in the network
ICANN and IANA
60 octets
13. What is the Fragment Offset field in the IPv4 header?
0x0800
Offset - in units of eight octets - from the beginning of the original header to the beginning of the fragment
RFC 1918
1 Determine how many subnets are required; 2 Determine how many hosts per subnet are required; 3 Determine the subnet mask for each subnet; 4 Calculate the network address for each subnet
14. What is the most commonly used Option field in the TCP header?
Used by a host to obtain the IP address associated with another host's MAC address
NIRs
Final
Maximum Segment Size (MSS)
15. Which protocol has mostly replaced Reverse ARP?
DHCP
Method where routers - by responding to ARP requests for IP addresses in different subnets - make themselves available to hosts with no default gateway configured
Maximum Segment Size (MSS)
4
16. What is the prerequisite for using the Urgent Pointer field in the TCP header?
URG flag set
10.0.0.0/8; 172.16.0.0/12; 192.168.0.0/16
255.255.255.240
Loose source routing; Strict source routing; Record route; Timestamp
17. What is the IPv4 Protocol number for ICMP?
NIRs
255.255.255.224
1
Both the TCP header and the encapsulated data
18. How does the layers of the TCP/IP protocol suite map to the 7 layers of the OSI model?
Class A 0; Class B 10; Class C 110; Class D 1110; Class E 1111
1-2 Network interface; 3 Internet; 4 Host-to-host; 5-7 Application
1
NIRs
19. What is the format of a UDP header?
Time Exceeded
198.18.0.0/15
Source Port (16-bit); Destination Port (16-bit); UDP Length (16-bit); Checksum (16-bit)
IP Precedence (3-bit); ToS (4-bit); Reserved (1-bit)
20. Which IPv4 address range is reserved for use in documentation and example code?
Final
Hardware type (16-bit); Protocol type (16-bit); Hardware address length (8-bit); Protocol address length (8-bit); Operation (16-bit); Sender hardware address; Sender protocol address; Target hardware address; Target protocol address
192.0.2.0/24
Identifier; Flags and Fragmentation Offset
21. Which IPv4 address range is reserved for self-identification on a local subnet?
Internet Protocol
0.0.0.0/8
Destination Unreachable
An ARP request issued by a host with its own IPv4 address as the target address
22. What is prefix /30 in decimal notation?
Both the TCP header and the encapsulated data
255.255.255.252
169.254.0.0/16
Local Internet Registry
23. What is the ARP Operation value for a Reverse ARP Reply?
Internet Protocol
17
Mostly large ISPs - enterprises - or academic institutions
4
24. What is added after the Option field in the TCP header?
Router#show arp
Class A 1-126; Class B 128-191; Class C 192-223; Class D 224-239; Class E 240-254
Padding of zeros to ensure that the header ends on a 32-bit boundary
An ARP request issued by a host with its own IPv4 address as the target address
25. What is the IPv4 Protocol number for OSPF?
89
20 octets
Router(config-if)#no ip proxy-arp
Hardware type (16-bit); Protocol type (16-bit); Hardware address length (8-bit); Protocol address length (8-bit); Operation (16-bit); Sender hardware address; Sender protocol address; Target hardware address; Target protocol address
26. What is added after the option field in the IPv4 header?
8
17
Padding of zeros to ensure that the header ends on a 32-bit boundary
255.255.255.224
27. What is the function of ICMP router advertisement and router selection messages?
6
Used by IRDP on some operating systems to discover local routers
Local Internet Registry
Router#debug arp
28. What is SYN?
Router Selection
Per-Hop Behaviour (PHB)
RFC 791
Synchronize
29. What is ICMP Type 9?
0
Number of octets to be added to the Sequence Number to indicate the end of the urgent data
Router Advertisement
Reset
30. What is the format of an IPv4 header?
Address Resolution Protocol
Version (4-bit); Header Length (4-bit); ToS (8-bit); Total Length (16-bit); Identifier (16-bit); Flags (3-bit); Fragment Offset (13-bit); TTL (8-bit); Protocol (8-bit); Header Checksum (16-bit); Source Address (32-bit); Destination Address (32-bit);
255.255.255.128
Final
31. What is the IPv4 Protocol number for IGMP?
NIRs
Internet Control Message Protocol
2
Echo
32. What is ICMP Type 11?
Method where routers - by responding to ARP requests for IP addresses in different subnets - make themselves available to hosts with no default gateway configured
1
Open Systems Interconnection
Time Exceeded
33. Specifies the format in which subnet masks are displayed in show command output
Router(config)#ip netmask-format {bit-count | decimal | hexadecimal}
8
The next sequence number that the source expects to receive from the destination
1
34. What is the minimum length of an IPv4 header?
1 Determine how many subnets are required; 2 Determine how many hosts per subnet are required; 3 Determine the subnet mask for each subnet; 4 Calculate the network address for each subnet
20 octets
DSCP (6-bit); ECN (2-bit)
Socket
35. What is the difference between the ToS and the DiffServ byte?
4
Time to Live
1-2 Network interface; 3 Internet; 4 Host-to-host; 5-7 Application
They are the same byte - but the names and value interpretations are different
36. What is the ARP Operation value for an ARP Request?
1
Used by a host to obtain the IPv4 address associated with its own MAC address
RIRs
192.88.99.0/24
37. What is ECE?
1
ECN-Echo
Used by a host to obtain the IP address associated with another host's MAC address
Router#debug arp
38. What is IRDP?
Padding of zeros to ensure that the header ends on a 32-bit boundary
4
Each router decrements the TTL
ICMP Router Discovery Protocol
39. What are the uses of gratuitous ARP?
Minimize Delay (1-bit); Maximise Throughput (1-bit); Maximise Reliability (1-bit); Minimize Monetary Cost (1-bit)
Duplicate address checks; Advertise new data-link identifiers; Update the ARP caches of hosts
Router Advertisement
Used by a host to obtain the IPv4 address associated with its own MAC address
40. What is ICANN?
1 Determine how many subnets are required; 2 Determine how many hosts per subnet are required; 3 Determine the subnet mask for each subnet; 4 Calculate the network address for each subnet
3
Final
Internet Corporation for Assigned Network Numbers
41. What is the maximum length of an IPv4 header?
60 octets
Per-Hop Behaviour (PHB)
Minimize Delay (1-bit); Maximise Throughput (1-bit); Maximise Reliability (1-bit); Minimize Monetary Cost (1-bit)
ICANN and IANA
42. Who allocates IP address space and AS numbers to RIRs?
Echo
ICMP Router Discovery Protocol
Protocols that include subnet masks in their routing updates
IANA
43. Which RFC defines the special use IPv4 address ranges?
IANA
Address Resolution Protocol
10.0.0.0/8; 172.16.0.0/12; 192.168.0.0/16
RFC 3330
44. What is the IPv4 Protocol number for EIGRP?
Acknowledgement
88
Internet Assigned Numbers Authority
Router#debug arp
45. Disables proxy ARP on an interface
Reset
Protocols that don't include subnet masks in their routing updates
Router(config-if)#no ip proxy-arp
Internet Service Provider
46. What is ARP?
More Fragments follow
Router(config)#ip arp proxy disable
Address Resolution Protocol
IP Precedence (3-bit); ToS (4-bit); Reserved (1-bit)
47. What is the the MF-bit in the IPv4 header?
Echo Reply
0x0800
More Fragments follow
Congestion Window Reduced
48. What is PSH?
Push
Redirect
0x0800
Final
49. What is ICMP Type 8?
Don't Fragment
0 Routine; 1 Priority; 2 Immediate; 3 Flash; 4 Flash Override; 5 Critical; 6 Internetwork Control; 7 Network Control
Echo
255.255.255.240
50. What is URG?
Urgent
IANA
Protocols that don't include subnet masks in their routing updates
4